Составте алгоритм нахождения наименьшего из трех значений. ееееееееее!

Составте алгоритм нахождения наименьшего из трех значений.Помогитеееееееееее!

  • Допустим, в языке есть встроенная функция

    Min(a,b) которая определяет мин из двух значений. Тогда алгоритм выглядит так

     

    х=Мin(a,b);

    x=Min(x,c); 

     

    А если нужно найти мин из N чисел, которые запрятаны в массив А(n), то так

     

    x=999999999999999999999; // какое-то ОЧЕНЬ большое число

     

    Для ц=1 по N цикл

           x = Min(x,A(ц));

    КонецЦикла;

     

    А что, если такой функции в языке нет, спросишь ты, тогда её нужно написать самому, например, так

     

    Функция Min(a,b)

        Если a<b Тогда

              Возврат(а);

        Иначе

              Возврат(b);

         КонецЕсли;

    КонецФункции

     

    Вот и всЁ! Учитесь мыслить алгоритмически структурно, разбивая сложный алгоритм на ряд простых и понятных, и всё будет очень просто.

    Успехов!

     

Комментарии 1

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *